** NORMAS DEL FORO **
Inicio del foro Inicio del foro > Access y VBA > Access y VBA
  Mensajes nuevos Mensajes nuevos RSS - Problema con Microsoft Forms 2.0
  Preguntas frecuentes Preguntas frecuentes  Buscar en el foro   Eventos   Registro Registro  Iniciar sesion Iniciar sesion

Problema con Microsoft Forms 2.0

 Responder Responder
Autor
Mensaje
Otesanek Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 26/Marzo/2010
Localización: España
Estado: Sin conexión
Puntos: 3
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Otesanek Cita  ResponderRespuesta Enlace directo a este mensaje Tema: Problema con Microsoft Forms 2.0
    Enviado: 14/Febrero/2018 a las 22:04
Tengo, desde hace años, un formulario con varios controles SpinButton de Microsoft Forms 2.0.
Hace unas semanas (supongo que tras una actualización o, quizás, instalación de algo) desaparecieron. Están los controles, pero sin objetos, y en la pestaña Datos de las Propiedades falta el campo Origen del control.
Si intento agregar cualquier control de Forms 2.0 me lanza este mensaje: «Error durante la operación sobre el objeto OLE. Es posible que no esté registrado el servidor OLE. Para registrarlo, vuelva a instalarlo.»

Copio la base de datos en otro ordenador. Funciona.

El primer ordenador corre Windows 10 Home y el segundo Windows 10 Pro. Ambos se actualizan automáticamente y en este momento tienen la misma release.
En los dos ordenadores he instalado el mismo Access 2010, perfectamente legal.
Por supuesto, he reparado Access, lo he reinstalado e, incluso, he copiado el archivo FM20.dll del segundo al primero, por si estuviera corrupto.

Si alguien me puede orientar sobre la naturaleza del problema le quedaré muy agradecido.
Arriba
prga Ver desplegable
Moderador
Moderador


Unido: 16/Noviembre/2004
Localización: España
Estado: Sin conexión
Puntos: 2944
Opciones de entrada Opciones de entrada   Gracias (1) Gracias(1)   Cita prga Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 15/Febrero/2018 a las 00:59
Hola.
No se si será el problema, pero a partir de una actualización, al importar en una base de datos nueva "todo" lo de otra base, se dejaron de importar los formularios forms 2.0
Sí fuese este el problema, una solución pasa por:
1º.-En una base de datos que funcione exportar desde el VBA el Formulario forms 2.0 
2º.-En la base de datos que no funciona, importa el fichero exportado anteriormente.
A mi me funcionó con un treeview hecho a partir de un forms 2.0
Espero que ayude a resolver la duda
Un saludo a todos

Arriba
Otesanek Ver desplegable
Nuevo
Nuevo
Avatar

Unido: 26/Marzo/2010
Localización: España
Estado: Sin conexión
Puntos: 3
Opciones de entrada Opciones de entrada   Gracias (0) Gracias(0)   Cita Otesanek Cita  ResponderRespuesta Enlace directo a este mensaje Enviado: 15/Febrero/2018 a las 14:00
Gracias por responder, pero no ha dado resultado.
Arriba
 Responder Responder
  Compartir tema   

Ir al foro Permisos de foro Ver desplegable